DirectX 診断ツール

Microsoft® DirectX® 診断ツールのヘルプの内容は、以下のとおりです。

  • DirectX 診断ツールについて
  • トラブルの原因となる事項
  • DirectX コンポーネントをテストする
  • 既定の動作を上書きする


DirectX 診断ツールについて

Microsoft® DirectX® 診断ツールを使用すると、システム上の DirectX アプリケーション プログラミング インターフェイス (API) コンポーネントおよびドライバについての情報を取得できます。また、サウンドやグラフィックスの出力、および Microsoft DirectPlay® サービス プロバイダをテストすることもできます。さらに、一部のハードウェアのアクセラレータ機能を無効にすることもできます。

診断ツールを使用すると、サポートの問い合わせ時に技術者に伝える情報を収集できます。この情報は保存したり、電子メール メッセージに添付できます。

情報は一連のページに表示されます。以下の いずれかの方法でページ間を移動できます。

  • タブをクリックします。
  • [次ページ] をクリックします。
  • タブに入力フォーカスがある場合、←キーまたは→キーを押します。

このツールでのテーブルの表示方法を指定できます。そのためには、テーブルの行を並べ替える列を選択します。列の上部の見出しをクリックすると、列中の項目に基づいてアルファベット順または数値順にテーブルが並べ替えられます。並べ替えの順序を逆にするには、もう一度列の見出しをクリックします。

[情報をすべて保存] をクリックすると、すべての情報をテキスト ファイルに保存できます。

注

  • ディスプレイ カードのメモリ量などの情報は、大まかな数値になる場合があります。


トラブルの原因となる事項

Microsoft® DirectX® アプリケーションの実行中に問題が発生した場合は、DirectX 診断ツールを使用すると、トラブルの原因を見つけるのに有効です。トラブルの原因となる事項の一部を以下に示します。

  • 間違ったバージョンの DirectX コンポーネント - [DirectX ファイル] タブの [注意] で、ベータ ファイルおよびデバッグ ファイルについての警告があるかどうかを確認します。ベータ ファイルは初期のテスト用バージョンであるため、市販のアプリケーションと共にインストールしないでください。デバッグ バージョンはプログラムの開発に使用されるものであるため、これも最終製品と共にインストールしないでください。デバッグ バージョンのコンポーネントがインストールされていると、製品版のコンポーネントがインストールされている場合よりも、実行速度が遅くなる場合があります。
  • ハードウェア アクセラレータの欠如 - Microsoft DirectDraw® または Direct3D® ハードウェア アクセラレータが利用できない場合、一部のプログラムでは実行速度が遅くなるか、動作しなくなります。[ディスプレイ] タブの [DirectX の機能] で、DirectDraw アクセラレータ、Direct3D アクセラレータ、または AGP サポートに "使用不可" と表示されていないかどうかを確認します。表示されている場合は、ハードウェアのアップグレードを検討してください。
  • デバイスが接続されていない - ジョイスティックやその他の入力デバイスが応答しない場合、正しくセットアップされていない可能性があります。デバイスが DirectX 診断ツールの [入力] タブに表示されていることを確認します。表示されていない場合は、コントロール パネルからデバイスを追加します。
  • 署名されていないドライバ - Microsoft では、最新バージョンの DirectX との完全互換性について、署名されていないドライバをテストしていません。こうしたドライバは、該当するコンポーネントのタブに表示されます。

注 : ハードウェア アクセラレータをサポートしているリモート システムでターミナル サービスを実行する場合、DirectX 診断ツールはハードウェア アクセラレータをサポートしていることを示す場合があります。ただし、ターミナル サービスではハードウェア アクセラレータを使用できないため、このサポートは利用できません。


DirectX コンポーネントをテストする

システムに接続されているモニタを使用して、Microsoft® DirectDraw® および Direct3D® をテストできます。また、WAVE 出力デバイスごとに DirectSound® をテストしたり、ミュージック ポートごとに DirectMusic® をテストすることもできます。

DirectX 機能をテストするには、目的のタブで [テスト] をクリックして、表示されるメッセージを読み、テスト結果を目や耳で確認します。テストを実行するたびに、テストが成功したかどうか確認するメッセージが表示されます。[いいえ] をクリックすると、テストの実行は停止されます。

DirectMusic の場合、テストは 1 つだけです。音楽の演奏が正しく行われているか、または正しく行われていないことを確認した場合に、[OK] をクリックします。

Microsoft DirectPlay® 機能は、利用できるどのサービス プロバイダに対してもテストできます。

DirectPlay をテストするには

  1. [ネットワーク] タブの [DirectPlay のテスト] をクリックします。[DirectPlay テスト] ダイアログ ボックスで、ユーザー名を入力し、サービス プロバイダを選択します。[新しいセッションの作成] をクリックし、[OK] をクリックします。モデム接続を選択した場合は、[モデム接続] ダイアログ ボックスの [応答] をクリックして、モデムを自動応答モードにします。
  2. 最初のコンピュータとの選択済みの接続を確立できる別のコンピュータで、Microsoft DirectX® 診断ツールを実行します。[DirectPlay のテスト] をクリックして、別のユーザー名を入力します。次に、サービス プロバイダを選択して [既存のセッションに参加] をクリックし、[OK] をクリックします。

    接続の種類によっては、電話番号などの追加情報の入力を求められる場合があります。ローカル ネットワークでの TCP/IP 接続の場合は、空白のままにします。

  3. 2 番目のコンピュータには、1 番目のコンピュータで作成したセッション名が載った [セッションの一覧] が表示され、この一覧でセッション名をクリックし、[OK] をクリックします。
  4. 両方のコンピュータにチャット ダイアログ ボックスが表示されます。一方のコンピュータのボックスにメッセージを入力し、[送信] をクリックします。このメッセージは、両方のコンピュータのチャット ダイアログ ボックスのスクロール領域に表示されます。


既定の動作を上書きする

[サウンド] タブで、スライダを動かしてハードウェアのアクセラレータ レベルを設定できます。このレベルは、Microsoft® DirectX® 診断ツールを終了した後でも有効です。

アクセラレータを利用できる場合は、Microsoft DirectDraw® または Direct3D® のハードウェア アクセラレータを無効にします。ハードウェア アクセラレータを無効するには、ディスプレイ デバイスの [ディスプレイ] タブに移動し、[無効] をクリックします。ハードウェア アクセラレータを無効にすると、DirectX 診断ツールを終了した後でも、アプリケーションでハードウェア アクセラレータを使用することはできません。ハードウェア アクセラレータを使用できるようにするには、[ディスプレイ] タブの [有効] をクリックします。

注

  • DirectDraw アクセラレータを無効にすると、Direct3D のアクセラレータも無効になります。

DirectDraw 全画面表示アプリケーションで設定されたモニタのリフレッシュ レートを上書きすることもできます。上書きを行うのは、アプリケーションの表示中に問題が生じて、アプリケーションで設定されているリフレッシュ レートが無効な場合のみにしてください。

リフレッシュ レートの上書きを設定するには

  1. [それでも問題が解決しない場合] タブで、[上書き] をクリックします。
  2. [DirectDraw リフレッシュ レートの上書き] ダイアログ ボックスで、編集ボックスをクリックし、モニタに有効なリフレッシュ レートを入力します。

    このとき、[上書き値] は自動的にオンになります。

  3. [OK] をクリックします。

リフレッシュ レートの上書きを取り消して、DirectDraw アプリケーションが独自にリフレッシュ レートを設定できるようにするには

  1. [それでも問題が解決しない場合] タブで、[上書き] をクリックします。
  2. [DirectDraw リフレッシュ レートの上書き] ダイアログ ボックスで、[既定値] をクリックし、[OK] をクリックします。